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1 Legal Notice

Copyright © 2010 Nokia Corporation. All rights reserved.

Nokia and Nokia Connecting People are trademarks or registered trademarks of Nokia Corporation. Java
and all Java-based marks are trademarks or registered trademarks of Sun Microsystems, Inc. ActiveState
and ActivePerl based marks are trademarks and or registered trademarks of ActiveState Software Inc. Other
product and company names mentioned herein may be trademarks or trade names of their respective
owners.

Disclaimer

The information in this document is provided “as is,” with no warranties whatsoever, including any
warranty of merchantability, fitness for any particular purpose, or any warranty otherwise arising out of
any proposal, specification, or sample. This document is provided for informational purposes only.

Nokia Corporation disclaims all liability, including liability for infringement of any proprietary rights,
relating to implementation of information presented in this document. Nokia Corporation does not warrant
or represent that such use will not infringe such rights.

Nokia Corporation retains the right to make changes to this document at any time, without notice.

License

A license is hereby granted to download and print a copy of this document for personal use only. No other
license to any other intellectual property rights is granted herein.
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2 Introduction

2.1 About this Installation Guide

This document describes what you need to know and do to install the Nokia Symbian^3 SDK. This document
also includes instructions on how to verify that your environment is properly configured.

The Nokia Symbian^3 SDK enables application development for Nokia Symbian^3 devices. The SDK is based
on Nokia Symbian^3 and includes all key functionality needed for application development
(documentation, API reference, add-on tools, emulator, target compiler), excluding the Integrated
Development Environment (IDE).

2.2 Who Should Read this Guide?

You should read this guide if you plan to install the Nokia Symbian^3 SDK.

2.3 Typographical Conventions

Table 2.1: Typographical conventions

Notation Explanation
Courier • Text that you enter (as opposed to system prompts and

responses)
• File paths
• Commands
• Program code

Italic • Names of books and documents
• New terminology

Bold Names of Microsoft Windows menus, commands, buttons, and icons.

URL link Active link to an external URL.
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3 System Requirements

Before installing the SDK, check that you have the minimum hardware and software requirements listed in
this section. With these minimum requirements, you can run the SDK as a standalone application. If you
plan to use the SDK with an integrated development environment (IDE), please make sure you have the
requirements mandated by the IDE in question.

3.1 Hardware Requirements

3.1.1 Recommended Hardware Configuration

The recommended hardware configuration for installing and running the SDK:

• Minimum 2 GHz Pentium PC, 3 GB of memory.

• At least 10 GB free disk space, other requirements according to the IDE used.

• Installation/Uninstallation and using of the SDK requires local admin rights.

• Other Requirements as required by IDE used.

3.1.2 Minimum Hardware Configuration

The minimum hardware configuration for installing and running the SDK:

• 2 GHz processor.

• 1024 MB RAM.

• 16-bit color.

• 1024x768 resolution.

• 3 GB free hard disk space.

• A Microsoft Windows compatible sound card (required for audio support).

3.2 Software Requirements

The minimum software requirements for installing and running the SDK are listed below.

• Active Perl v5.6.1 (see Section 4.2 Active Perl installation on page 6 for details); - 'perl -v' command
can be used to find existing perl versions.

• Java Runtime version v1.5.0 or later (see Section 4.3 Java Run-Time installation on page 6 for details);
-'java -version' command can be used to find existing java versions.

• ARM RVCT compiler v2.2 build 593 or newer is supported for ARMV5 compilation.

• GCCE v4.4.1 is supported.

The following operating systems are supported:

• MicrosoftTM Windows XP Professional SP2 & SP3.

• MicrosoftTM Windows 7

3.3 Additional Installation Requirements

• All installations must be performed using an administrator account. Otherwise, some environment
variables may not be set correctly.

• The SDK must be installed in a path that does not contain any whitespace characters.

• The SDK, IDE and your project files must be located on the same logical drive as build tools to work
correctly in all situations.
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4 Installing the SDK

4.1 Prerequisites

Before installing the SDK you should have installed and configured:

• Perl (see Section 4.2 Active Perl installation on page 6 for details).

• Java (see Section 4.3 Java Run-Time installation on page 6 for details).

• All peripherals you are going to use (see Supported Accessories on page 23 for details).

All installations should be performed with an account that belongs to local administrators group. You should
close all other applications before starting the installer.

4.2 Active Perl installation

ActivePerl 5.6.1 or higher is required and must be installed before installing this SDK. However, the user
can find the Active Perl from the <Symbian3_SDK_installed_directory>\epoc32\tools
\distrib .

ActivePerl must be installed on your computer with administrator rights. Otherwise the PATH environment
variable is not set correctly.

4.3 Java Run-Time installation

Java Run-Time (JRE) 1.5.0 is required to use emulator Preferences and other Java components.

Java Run-time can be downloaded from Sun Developer Network Downloads http://developers.sun.com/
downloads/. (JRE is included in J2SE.).

JRE must be installed on your computer with administrator rights. Otherwise the PATH environment variable
is not set correctly.

4.4 Running the SDK Installer

This section provides the basic steps for installing the SDK. By following the steps below you will install the
SDK to your PC and be able to start application development.

Once you have downloaded the installation package (.zip file) on you PC, installing the Nokia Symbian^3
SDK takes place through the SDK Installer, that is, the InstallShield Wizard. The following will take you
through the steps needed to install the SDK.

1 Start the SDK installation by running the installation executable setup.exe located in the SDK delivery
ZIP file. The Installshield wizard panel appears:
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2 Click the Next button to continue.

The License Agreement dialog is displayed:

Read the license agreement carefully.
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3 After reading (and accepting) the license agreement, click the I accept the terms of the licensee
agreement radio button and click Next.

Note: If you do not accept the license agreement, installation of the SDK is cancelled.

The Setup type and destination folder dialog is displayed:

The SDK installer provides the following installation options:

• Complete: Installs all program features.

• Custom: Allows you to select which features to include in the SDK (see step 4 below for a list of
installation options).

Select the type of installation that you want by clicking the appropriate radio button.

If you do not want to install the SDK to the proposed default directory (C:\Nokia\devices) you can
browse the installation directory by clicking the Browse button.

Note: The installation directory should not contain whitespaces.

Note: As the installation directory must be same as the name of the device, the installer
always creates Nokia\devices\Nokia_Symbian3_SDK_v1.X directory under the
selected directory.

Once you have selected the installation type and (possibly) defined the installation directory, click
Next.

• If you select the Complete installation option, proceed to step 5.
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• If you select the Custom installation option, proceed to step 4.

4 If you selected the Custom installation option, the Select Features dialog is displayed:

The options are:

• CPP -- Symbian C++ features

• C++ Documentation -C++ specific documentation.

• Symbian Examples - Symbian C++ examples.

• Dev tools for C++ -This contains all the CPP API headers and compiler toolchains for WINSCW and
ARM build.

• IDE Integration -Integrate SDK documentation into Carbide.C++.

• MIDP--Symbian Java features

• MIDP Documentation -MIDP specific documentation.

• MIDP Examples -MIDP examples.

• Dev tools for MIDP -It contains binaries and Java APIs for MIDP development.

• IDE Integration -Integrate SDK documentation into Eclipse and Netbeans.

• COMMON--This contains all the common components required for both C++ and Java application
development.

• Common Documentation -Common documentation.

• Common Tools -This contains Symbian tools such as MBM viewer, Symbian BT driver, ECMT etc..

• Icon -Common icon.

• Emulator -Emulator.

Click the features that you want to include in the SDK installation and click Next.

5 The Choose Destination Location dialog is displayed:
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Define your Eclipse installation directory by clicking Browse and then Next.

C++ users may skip this stage by clicking NEXT button, as JAVA documentation is not relevant for C++
developers.

6 The Start Copying Files dialog is displayed. Click Next to start the SDK installation. (If you want to
modify the installation settings, click Back and modify them as needed.)
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7 The Setup Status dialog is displayed. The SDK installation status is displayed in the Setup Status.

8 If you already have other SDKs installed on your PC, the InstallShield Wizard will prompt you to select
one of them as the default SDK. Select the appropriate SDK in the following dialog and click Next.
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9 If you do not have the GCCE 4.4.1 Toolchain installed on your PC, the following dialog will appear,
prompting you to install it:

As the GCCE 4.4.1 Toolchain contains the GCCE compiler needed to build Symbian^3 applications for
real devices, click Yes to the question and follow the instructions of the GCCE 4.4.1 Toolchain installation
wizard

Once the GCCE 4.4.1 Toolchain has been installed, proceed to step 10.

10 To complete the installation, click Finish in the Installation complete dialog.
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The SDK is now fully installed on your PC. You can verify this through the Windows Start menu by, for
example, opening the SDK Help by selecting Start > All Programs > Nokia Developer Tools >
Symbian^3 SDK > v1.X> SDK Documentation.

More detailed instructions on how to verify the SDK installation that you have just performed are
provided in Chapter 5 Verifying SDK Installation on page 14.
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5 Verifying SDK Installation

Once you have installed the SDK and example applications, you can verify that your environment is properly
configured.

Note: To verify the installation according to the instructions provided here, you will need to have
access to the Hello World Basic example application. Example applications are delivered with the
SDK and installed by default to the<Nokia_Symbian3_SDK_installation_directory>
\Examples\
Example applications are installed only in two modes 1. Typical installation and 2. If you select
examples in custom installation.

5.1 Verifying command line tools

To check that SDK command line tools function correctly, you can go through the following sequence:

1 Open the Command Prompt.

2 Set the Nokia Symbian^SDK as the default device with the devices command:

devices -setdefault @Nokia_Symbian3_SDK_v1.x:com.nokia.symbian
3 Go to the directory that contains the Hello World Basic example application. In a default installation it

can be located with the cd command:

<Nokia_Symbian3_SDK_installation_directory>\examples\symbian\gui
\helloworldbasic

4 Use the cd command to go to the group directory:

cd group
The group directory contains the bld.inf and helloworldbasic.mmp files.

5 Building using Building using SBSv2 Tools Chain

• sbs -c winscw_udeb for WINSCW

• sbs -c armv5_urel for RVCT

• sbs -c armv5_urel_gcce4_4_1 for GCCE 4.4.1

6 Building using SBSv1 (ABLD) Tool Chain

• Enter the bldmake bldfiles command. This generates the necessary build directories.

• Enter the abld build command.

The build script starts the make command that will both compile and link the application for the
emulator.

7 If your environment has been set up correctly, the build goes through without errors and you can run
the Hello World Basic application in the emulator by issuing the epoc command. (Notice that it may
take a while for the emulator to open.)

The emulator starts and displays the application grid. To verify that the Hello World Basic application
has been properly compiled and can be run on the emulator, do the following:

• Open Applications  folder from the emulators main menu.

• Once the Applications folder has been opened, use the touch feature to locate the Hello World
Basic application icon.

• Open the Hello World Basic application.
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Locating and opening the Hello World Basic application in the emulator’s application grid means that
the application has been compiled and can be run on the emulator. In other words, the command
line tools of your SDK installation are OK.

5.2 Verifying IDE configuration

To check that the SDK functions correctly with an IDE, you can go through the following sequence (the IDE
used in this example is Carbide.c++)

1 Start the Carbide.c++ IDE.

2 Once the Carbide.c++ IDE is opened, it should display a message informing you that the Carbide.c++
documentation plug-in has been discovered. Click Restart

3 Once the Carbide.c++ IDE is restarted, go to Help > Help Contents and verify that the SDK Help is included
in the Carbide.c++ Help system.

4 In the Carbide.c++ IDE, go to Window > Preferences... > Carbide.c++ > SDK Preferences and verify
that the SDK is listed in Available Symbian OS SDKs.
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6 Configuring the Emulator

Once the SDK has been installed, you need to configure Bluetooth and Ethernet for the emulator. For detailed
instructions on how to do this, please refer to the Emulator guide in the SDK Help. The SDK Help can be
opened through the Windows Start menu by choosing Start > All Programs > Nokia Developer Tools >
Symbian3SDK > v1.X > SDK Documentation.
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7 SDK Registration Wizard
Once you have installed the SDK, you will be given a trial run for 14 days. After 14 days of your trial you will
be asked for registration automatically. You need to have a registration serial number for the SDK product,
which you can get from Forum Nokia site.

You have the serial number:

If you are having the product serial number, please check the relavent check box in the SDK registration
wizard and click the next button. In the next window you will be asked for the Forum Nokia user name and
the serial number. Click finish once you are done. Else you can even import the registration file.

Registration file should be in the following format.

• Product-Key=XXXX (Found in the SDK registration wizard window).

• Username=YYYY (Forum Nokia UserID).

• Serial-Number=ZZZZ(Serial key from Forum Nokia).

Copy the above information in a text file and then import it.

You don’t have the serial number:

If you don’t have the serial number then please check the relavant check-box in the SDK registration wizard
and click the next button. Here, you will be asked whether you have internet connection or not.

• I have internet connection(Online registration):

The registration wizard will launch the default browser and will guide you through the registration
process. Please note that you need to have Forum Nokia userID for this registration.

• I don’t have Internet connection:(Offline registration):

If you don’t have an internet connection, then you can use a computer that has internet connection to
open the page http://www.forum.nokia.com/GetSerialNumber. You can enter the product key available
from the registration window to get the serial key. Enter this key for the SDK registration.

Note:  You can register to Forum Nokia yourself without waiting for the SDK to prompt for it. This
can be done through the “Register Now” option provided in the “Help” menu of the menu bar.
This will take you to the Forum Nokia site for registration. If you have already registered the SDK
with the product key, “Register now” option from the menu bar will disappear.
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8 Uninstalling the SDK

To uninstall the SDK, do the following:

1 In the Windows Start menu, go to Start > Settings > Control Panel.

2 In the Control Panel double click the Add/Remove Programs icon.

3 In the Add/Remove Programs window, select the Symbian SDK from the list of currently installed
programs.

4 With the Symbian SDK selected, click Remove.

The InstallShield window opens.

5 When prompted to confirm that you really want to uninstall the SDK, click Yes.

6 Once the SDK has been removed from your PC, InstallShield informs you of this: Click Finish to exit the
InstallShield application.

Note: Always uninstall the SDK through the Add/Remove Programs application, as described
above. Do not attempt to remove the SDK contents manually. For example, in the Windows
Explorer.

However, if you have used the emulator prior to uninstalling the SDK there may remain some SDK-
related files and folders in the C:\Nokia\devices\Nokia_Symbian3_SDK_v1.X directory
even after removing the SDK through the Add/Remove Programs application. These files and
folders need to be removed manually by, for example, deleting them in the Windows Explorer.
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9 Multiple SDKs on the Same Computer

9.1 Multiple SDK instances on the same compute

Installing multiple instances of the SDK is supported in the Nokia Symbian^3 SDK.

To install additional instances of the SDK, follow normal installation steps, as described in Installing the
SDK on page 6. Once an additional SDK has been installed, it is displayed in the Windows Start menu by,
for example, opening the SDK Help by selecting Start > All Programs >Nokia Developer Tools > Symbian3
SDK> v1.X > SDK Documentation.

Notice, that the new SDK instance is numbered in the Start menu as v1.0_2. The same consecutive
numbering is also applied in the default SDK installation directory, followingly:

First installed SDK instance: C:\Nokia\devices\Nokia_Symbian3_SDK_v1.x\
Second installed SDK instance: C:\Nokia\devices\Nokia_Symbian3_SDK_v1.x_2\
Third installed SDK instance: C:\Nokia\devices\Nokia_Symbian^3_SDK_v1.x_3\

9.2 Devices basics

Since Symbian OS 7.0s all Symbian SDKs have supported the devices mechanism to handle multiple SDK
installations on same computer. The devices command replaced the EPOCROOT environment variable
used by SDKs based on Symbian OS 6.0 and 6.1.

The devices command is used to change between different SDKs tool chains. All SDK commands, such as
bldmake bldfiles use the devices mechanism to query location of include files, link libraries and
required SDK tools. To get a list of installed SDKs, or "devices", enter the following command in the command
prompt:

C:\>Nokia\Devices
A list of installed SDKs is displayed, for example:

Nokia_Symbian3_SDK_v1.x:com.nokia.symbian – default
Nokia_Symbian3_SDK_v1.x_2:com.nokia.symbian
The default device is indicated with – default. In the above case the default device is
Nokia_Symbian3_SDK_v1.x:com.nokia.symbian. This device is the one that is used when you call
Symbian OS SDK commands such as epoc. To switch between devices, use the -setdefault option of
the devices command:

C:\Nokia\devices -setdefault @Nokia_Symbian^3_SDK_v1.x_2:com.nokia.symbian
Notice, that @ is part of the command.

You can verify that the default device has been changed by listing all devices with the devices command:

C:\Nokia\devices
The list of installed SDKs is displayed with the new default device:

Nokia_Symbian3_SDK_v1.x_2:com.nokia.symbian – default
Nokia_Symbian3_SDK_v1.x:com.nokia.symbian
To view information about any of the installed SDK devices, the devices -info option can be used:

C:\>devices -info @Nokia_Symbian3_SDK_v1.x_2:com.nokia.symbian
Device: Nokia_Symbian3_SDK_v1.x_2:com.nokia.symbian
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Root is C:\Symbian\devices\Nokia_Symbian3_SDK_v1.x_2
Tools path is C:\Symbian\devices\Nokia_Symbian3_SDK_v1.x_2\epoc32\tools
This information is utilized by Symbian commands. When, for example, the epoc command is executed, a
stub command is launched at C:\Program Files\Common Files\Symbian\tools. The command
uses the path information stored by the devices command to launch the actual emulator at <Tools_path>
\Epoc32\release\winscw\udeb\epoc.exe.

Note: When building a software project with multiple SDKs, please note the following. After you
have changed the device, remember to regenerate your IDE project and/or makefiles by using the

sbs -m <TARGET> and sbs -c <TARGET> commands. The <TARGET> can be WINSCW ,
ARMV5 or GCCE
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10 Further Information

Once you have installed the SDK, you can find information on how to use the SDK from the SDK Help. You
can open the SDK Help from the Windows Start menu by selecting Start > All Programs > Nokia Developer
Tools > Symbian3 SDK > v1.X> SDK Documentation.

For late-breaking information, please refer to the Release Notes, which you can open directly from the
Installation Package (ReleaseNotes.txt).
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Appendix A Supported IDEs

IDEs for C++ development

The following IDEs are supported by the SDK for C++ development:

• Carbide.C++ v2.6 and higher.

Note: SDK documentation is integrated automatically into the Carbide.c++ IDE Help.

IDEs for Java development

• Eclipse Pulsar for Mobile Java Developers 3.5 or higher.

Note: SDK documentation is integrated automatically into the Eclipse IDE Help.

• NetBeans 6.8 and 6.9.

Note: SDK documentation is integrated automatically into the NetBeans IDE Help, only when
the user has installed the NetBeans before the SDK is installed

However, if the user has installed the SDK without installing the Netbeans. Do the following to
get the IDE doc integrated with the Netbeans :

• From the Menu Bar choose Tools > Plugins

• Plugins Dialog Box appear, Choose the tab Downloaded

• Click Add Plugins Button

• Locate the NBM file from <Symbian3_SDK_installation_directory>
• Click OK

• Click Install button, SDK documentation is integrated automatically into the NetBeans IDE
Help

Note: Nokia Symbian^3 SDK supports usage of SUN's Universal Emulator Interface (UEI) interfaces
(OTA and D-flags are not supported by the SDK). Consequently, you can use any IDE supporting the
UEI together with the Symbian SDK to develop Java MIDP applications.
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Appendix B Supported accessories

Nokia Symbian^3 SDK supports the following accessories:

Bluetooth cards and dongles

• TDK BRBLU04

• Brainboxes BL-500

• Casira (HCI BCSP & H4)

• Cards supporting HCI BCSP

• Wrapper for Bluetooth USB dongles (with CSR chipset) at H4 mode

Network cards

Ethernet cards that comply with IEEE 802.3 standards (Ndismedium802_3).

Note: See IDE documentation for minimum hardware requirements.

USB versions

• version 1.0

• version 1.1

• version 2.0
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